MySQL Forums
Forum List  »  Replication

Exec_Master_Log_Pos doesn't move (invalid position?)
Posted by: Eric Coll
Date: October 26, 2012 04:11PM

We have a slave machine with the following issue:

- Both IO and SQL replication threads are running
- No errors are reported

However, the Exec_Master_Log_Pos never changes, and the slave continues falling seconds behind. So, replication appears to work, but it's not working.

We tried to write down the current replication coordinates, reset the slave, and try to start replication at those coordinates, but we get an error from the master saying that the position is invalid.

Then we re-started replication at the current master coordinates (an ignoring errors) and the replication worked for a while, but then stop with the same issue.

I read about certain cases where the master crashes and creates a new bin log.

However, this case is odd. The bin log is the same in the master and the slave, but the slave position is larger than the master position.

So, the slave is trying to read past the end of the file.

Any ideas on how could we at least troubleshoot this issue?


Background:
- we had one slave working fine
- we created a second slave following this procedure
- stop first slave
- get first slave execution coordinates
- snapshot first slave to second slave
- start first slave
- start second slave at the coordinates taken on the first step

Options: ReplyQuote


Subject
Views
Written By
Posted
Exec_Master_Log_Pos doesn't move (invalid position?)
4376
October 26, 2012 04:11PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.