MySQL Forums
Forum List  »  Backup

[URGENT]can not restore after upgrading.
Posted by: Chagh
Date: August 28, 2005 12:00AM

hi all,

i had MySQL 5.0.7 on win xp sp 2. it worked properly but did not support triggers in a proper manner, so i decided to upgrade to 5.0.10 or 5.0.11.

i upgraded to MySQL 5.0.11 bu i could not see my SPs and i couldn't create a new SP also (i think it is a bug and it is reported. i uses mysql_fix_privilege_tables but it didn't change any thing).

then i uninstalled 5.0.11 and installed 5.0.10. i couldn't see my SPs there also.

then i uninstalled 5.0.10 and removed my mysql directory from program files(i have it now in other place) uninstalled all mysql GUIs and restrted the computer.

then i installed 5.0.10 again(so not upgraded just installed.). and installed GUIs and then i tried to restore my db from my backups (these files were backed up from MySQL administrator.)
i had some different backups. one of them was only from my DB and other included mysql and information_schema db('cause i has stored procedures and i didn't think taking backups from db is enough. it just dumps tables and not views or SPs), restoring my backup file gave me some warnings about not creating information_schema tables and it completed.

but now i can not see any of my views, SPs, functions and triggers in my DB. i can see them in mysql db but they are not in my db which should contain them.

what can i do now? how can i restore my DB? and how can i use 5.0.10 and 5.0.11 to use both triggers and SPs?

your help would be greately appreciated.
Chagh

Options: ReplyQuote


Subject
Views
Written By
Posted
[URGENT]can not restore after upgrading.
3010
August 28, 2005 12:00AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.