MySQL Forums
Forum List  »  Backup

Re: Error 1062 while restoring backup
Posted by: Peter Warren
Date: March 13, 2013 10:01PM

You need to to avoid the primary keys and foreign keys check when restoring, when backing up, you need to add the disable keys statement before dumping a table.

Read more about the disable keys statement on the following page:

http://www.databasethink.com/mysql/backup/help/task-wizard/advanced-settings.php

Please search the string "Surround the INSERT statements with ALTER TABLE table_name DISABLE KEYS" on the page.

You can use a freeware to instead of mysqldump to dump your MySQL databases. It will automatically add the DISABLE KEYS statements in the SQL file:

Free Backup for MySQL

http://www.databasethink.com/mysql/backup-free/

Options: ReplyQuote


Subject
Views
Written By
Posted
7960
January 19, 2013 09:39PM
2526
January 20, 2013 10:24PM
2720
January 20, 2013 11:21PM
2094
January 23, 2013 03:30AM
Re: Error 1062 while restoring backup
2431
March 13, 2013 10:01PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.