MySQL Forums
Forum List  »  Backup

Restore backup leaves one database with no access
Posted by: marc fromm
Date: November 12, 2014 12:51PM

On the live server I have mysql-5.0.95-5.el5_9 in the dev server I have mysql-5.1.73-3.el6_5.x86_64.

When I restore backups created on the live server to the dev server only one of the databases has an access denied message in the browser from the php page that uses that database. The remaining databases have no access problems after the restore.

In phpMyAdmin if I select any of the databases and access the privileges information, all the databases report "Unkown column ‘Event_priv’ in ‘field list’"

If I run mysql_upgrade it corrects all of the above issues. Each time that I run mysql_upgrade, I am told mysql is already upgraded are you sure you want to run it again. I have to keep running it after every restore to solve the above problems.

What can I do to correct this issue so I don't have to run mysql_upgrade after each restore?


Options: ReplyQuote

Written By
Restore backup leaves one database with no access
November 12, 2014 12:51PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.