MySQL Forums
Forum List  »  Security

MySQL Default Password Issue
Posted by: Yawar Aziz
Date: March 08, 2018 04:29AM

Dear Professionals !!!

I am facing an issue while install MySQL 5.7.21-1 on CentOS 7.4. I am installing MySQL Community Server with its dependencies i.e. MySQL Community Clients, Libs & Common.

The problem is:
1) MySQL is not generating it's default password for root & /var/logs/mysqld.log is totally empty.
2) Let for instance, if I issue mysql_secure_installation command, even then it is not accepting any empty password (as at some helping forums, I read that sometimes there is no default password).
3) I also tried to generate "mysqladmin -u root password <new_password>" but even then the problem exists & I face the message "Error 1045 (28000): Access denied for user root using password YES" & "Error 1045 (28000): Access denied for user root using password No".

I also tried "skip-grant-privileges" but it's not working at all.

Strange thing is that I can easily install MySQL on RHEL 7.1 but CentOS is showing me problem. I have to install it on CentOS 7.4 so I seek your professional help.

Thank You

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL Default Password Issue
8931
March 08, 2018 04:29AM
1978
March 09, 2018 11:09AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.