MySQL Forums
Forum List  »  Security

Invalid --keyring-migration-source option.
Posted by: Karen Goh
Date: March 04, 2019 12:50AM

I have tried to re-set MySQL password since I can't log in to MySQL server on Windows10 without avail. Tried putting the reset password onto mysql-init.txt file, doesn't help.

Also, I tried to use MySQL>. Doesn't help.

So, I did the changes via mysqld.

But, I am getting the following error :

C:\Program Files\MySQL\MySQL Server 8.0.15\bin>mysqld --skdip-grant-tables

C:\Program Files\MySQL\MySQL Server 8.0.15\bin>mysqld flush privileges

C:\Program Files\MySQL\MySQL Server 8.0.15\bin>mysqld ALTER USER 'root'@'localhost' IDENTIFIED BY 'NEWpassword';

C:\Program Files\MySQL\MySQL Server 8.0.15\bin>mysqld -u root -p
Enter password: ********
mysqld: Can not perform keyring migration : Invalid --keyring-migration-source option.
2019-03-04T05:25:35.624994Z 0 [System] [MY-010116] [Server] C:\Program Files\MySQL\MySQL Server 8.0.15\bin\mysqld.exe (mysqld 8.0.15) starting as process 9196
2019-03-04T05:25:35.670562Z 0 [ERROR] [MY-011084] [Server] Keyring migration failed.
2019-03-04T05:25:35.693298Z 0 [ERROR] [MY-010119] [Server] Aborting
2019-03-04T05:25:35.693924Z 0 [System] [MY-010910] [Server] C:\Program Files\MySQL\MySQL Server 8.0.15\bin\mysqld.exe: Shutdown complete (mysqld 8.0.15) MySQL Community Server - GPL.

Hope someone can help me.

Options: ReplyQuote

Written By
Invalid --keyring-migration-source option.
March 04, 2019 12:50AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.