Posted by: Praveen TS
Date: February 21, 2009 11:56PM

Hi all,

Last week i met a friend, who has developed a product using MySQL 5.0.31Community. This product is very big and the important is he is suppose to launch a product on this month end.

The problem is, in MySQL 5.0.31community edition, The ONLY_FULL_GROUP_BY sql_mode is not enabled.

For ex:
select count(id),first_name from employee

will work without giving any error. But the query is wrong as there is no group by. This is error in oracle, pgsql. I dont know why MySQL supports this type of query.

Now the problem, the my friend intend to launch the product in linux server with MySQL 5.0.51 full edition.

The above said query will fail now. This MySQL version also gives the same error as it is in Oracle.

I told my friend to change the code, ask your developers to fix this bug.
He said, he dont have time to fix all this query as it appears in many places.

How to fix this in MySQL 5.0.51? I tried to run this using

set @@sql_mode ='';

but no useful. Still the same error.

Any suggestion?

Thanks in advance

Options: ReplyQuote

Written By
February 21, 2009 11:56PM
February 23, 2009 08:46AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.