Database unreachable unless I start the MYSQL Workbench
Posted by: Igor Brittner
Date: October 05, 2018 02:34AM

Hey guys,

I have this weird error/situation with one of our customer's mySQL database. Let's say I reboot the virtual machine where the database is running.. after the reboot when I try to open our customer's website, it says "cannot establish a database connection" although the service is on autostart and works flawlessly.

The strange thing is: when I start up the mySQL Workbench AND "log in" (to get the overview like server status etc.), the website suddenly works. It is not enough to just start the workbench though, you have to "log in" into one of your "MySQL Connections" (we only have one, but you get the point). I already tried to put the workbench in the autostart folder, which works.. but the website still can't establish a database connection until I explicitly "log in".

I thought the "autostart workbench" option will suffice, but unfortunately it is not since you are forced to open the SQL Editor. Once "logged in" solves the problem which is also strange.. means I must start up the workbench and log in ONCE and can close the workbench afterwards and the website will work.. very strange behaviour I couldnt find a solution for yet.. maybe you can help me? Is there an option where the database connection can be established without the need to start the workbench?


Kind regards and thanks in advance,
Igor

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.