Re: ERROR 1153: Got a packet bigger than 'max_allowed_packet' bytes
Posted by: Bogdan Nicolau
Date: March 17, 2009 10:02AM

It depends on what type of variable you setup. It's better to set it as system variable. The way to do it is like this:
set max_allowed_packet=1000*1024*1024;
set net_buffer_length=1000000;

To check if they're set, use:
select @@max_allowed_packet;

Note that the @@ operator works in global scope when setting up a variable, while when fetching a variable, it will retrieve the session one and if it's not found, the global one. The reason for using session vars is that they are set per client, so a mysql restart won't be necessary. They also don't require SUPER privileges.

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.