ERROR 1030 (HY000): Got error 28 from storage engine
Posted by: Paul Pikowsky
Date: April 18, 2006 10:06PM

I was adding an autoincremented key for a huge table, over 200,000 records and a FULLTEXT Seachable field too with entries that were also large. It was taking an awfully long time on my little 500 Mhz LAN Server and I thought it was done, but when I tried to have a look at the table, I got the error message, "ERROR 1030 (HY000): Got error 28 from storage engine".

I tried restarting from Linux and I got an error from Services, "mysqld dead but subsys locked" and after the restart, I couldn't connect from the client. I tried a complete system reboot and it appears I'm back in business. But, the autoincremented field that I added does not show up.

This is not a major disaster, but it is my first server problem.

What happened and what should I have done?

Options: ReplyQuote

Written By
ERROR 1030 (HY000): Got error 28 from storage engine
April 18, 2006 10:06PM
April 19, 2006 11:03AM
February 26, 2007 03:51AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.