MySQL Forums
Forum List  »  Connector/ODBC

Re: "...error in initializing provider. Catastrophic failure"
Posted by: john
Date: October 16, 2005 05:44PM

I have the same problem and have just come across this post. Like Gator, my connection works just fine up to the point where I try to use it as the source in step 3 of Word XP mail merge wizard - where you select recipients/Browse for data source/choose ODBC DSN type/ then select data source and optionally table name.

Unfortunately, the suggestion of leaving the table name blank doesn't solve the problem. I get to the next stage of opening the newly created xxx.odc data source, am prompted to select a table from the drop down list which displays correctly, and THEN get the same error as before "Word was unable to open the data source".

Excel opens the same source with no trouble at all, whether or not the table is preselected or left blank, when opened with a right-click then 'Open in Excel' on the data source name in My Data Sources.

Right click and View in Browser shows the name of the database, but displays no tables below that, when no table is preselected. Previously, when I had preselected a table, it displayed the table name, and field names as column headers, but just an error below that where the data should have been.

The same database/data source name connects fine via ODBC to both Microsoft Access, and WordPerfect 2000 mail merge.

Going all the way round the houses, and opening the data via the Other/Advanced choice in the Word merge step 3 doesn't do any better - the Test Data Source button works fine, but the Word still can't connect to merge data from the source when you try to use it.

Any further suggestions, anyone, to get it to work with Word 2002? I'm already using the latest available MySQL ODBC driver, v3.51 re-downloaded and reinstalled a couple of weeks ago (late September 2005), and have updated Office XP with Service Pack 3.

The machine runs Windows XP, SP2, also fully patched up to date. I've tried turning off both Norton AntiVirus, and Zone Alarm Pro, to see if either was blocking access, but it makes no difference.

The data is on another Linux server on the local network, running SME Server 6.0.1-01 (effectively a customised version of RedHat 7.3 or 7.4 - not sure which).

Options: ReplyQuote


Subject
Written By
Posted
Re: "...error in initializing provider. Catastrophic failure"
October 16, 2005 05:44PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.