MySQL Forums
Forum List  »  Connector/ODBC

Re: Can't find dependent library "libodbcinst.so.1"
Posted by: Bogdan Degtyariov
Date: July 17, 2017 01:00AM

Hi Julius,

In which file did you see the instruction to link against libmyodbc5.so?
That is probably some old version. It was taken out in the last versions because direct linking to ODBC driver is not a good idea unless talking about a small minority of very specific cases.

Even if you manage to link to the driver directly the stable work is not guaranteed.
There is no need to link directly to ODBC driver because UnixODBC will load the driver library on request when needed. As I mentioned before, just link against libodbc.so. Then you only need to put the configuration data inside odbcinst.ini/odbc.ini files and set environment variables ODBCSYSINI for odbcinst.ini and ODBCINI for odbc.ini.

Options: ReplyQuote




Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.