MySQL Forums
Forum List  »  Connector/ODBC

Access loses its connection/authentication to the MySQL database (randomly requests username password)
Posted by: Tom Conroy
Date: April 16, 2018 03:44PM

I have an Access 2002 Database running on Microsoft Server 2003 with MySQL OBDC connector version 5.1 linking to an offsite MySQL database.

For a couple of years, it ran perfectly. I could close and open the Access application and it would always have access to the tables in the MySQL database. Never a problem or a glitch. Never asked for the username or password since the day I created the connection to the MySQL database.

One day in the middle of its nightly operations it displays the login screen asking for the MySQL username and password to be filled in. (suspending its operation) In the morning I would type it in, and it would continue on. From that day on, it randomly pops the MySQL username and password connect screen as well as every time I restart the Access application.

Nothing that I know of on my end changed so I assume it was something on the other end. A new version of MySQL server or a setting change? Does anyone have and idea as to what might have changed?

This is driving me crazy as it is randomly preventing some mission-critical maintenance from happening overnight.

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.