MySQL Forums
Forum List  »  Connector/ODBC

ODBC connector 5.3.10 (and more) broken after windows 10 update?
Posted by: Ola Arwidsson
Date: May 29, 2018 05:13AM

Yesterday I noticed that some programs (written in Labview) stopped working on windows 10. The ODBC connector is not working correct anymore!
In ODBC connections/32 bit I can do TEST with success, but in labview programs I get the following errors:

1. with named server in ODBC connection:
"Possible reason(s):
ADO Error: 0x80004005
Exception occured in Microsoft OLE DB Provider for ODBC Drivers: [MySQL][ODBC 5.3(w) Driver]Unknown MySQL server host 'maindb.internal.thermoseed.se' (0) in NI_Database_API.lvlib:DB Tools Open Connec (String).vi->..."

2. with ip number for server:
"Possible reason(s):
ADO Error: 0x80004005
Exception occured in Microsoft OLE DB Provider for ODBC Drivers: [MySQL][ODBC 5.3(w) Driver]Can't create TCP/IP socket (10022) in NI_Database_API.lvlib:DB Tools Open Connec (String).vi->... "

This occured with ODBC connector 5.2, I managed to update to 5.3.10 but still same error.
Problem exist on both 32 and 64 bit windows 10 pro.
I tried to remove updates from windows 10, but don't know how to do that in a good way.

Options: ReplyQuote


Subject
Written By
Posted
ODBC connector 5.3.10 (and more) broken after windows 10 update?
May 29, 2018 05:13AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.