Re: Connector.Net 8.0.13 install failing
Posted by: Bill Volz
Date: January 15, 2019 03:27PM

Derek,

My install was failing with the same log results. My problem may not be the same as yours but I will tell you what I did to finally solve it.

I first ran the installer with verbose logging.
msiexec /i mysql-connector-net-8.0.13.msi /L*v install.txt

This logged a little more information including the below exception.

Beginning the Install phase of the installation.
See the contents of the log file for the C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_8.0.13.0__c5687fc88969c44d\MySql.Data.dll assembly's progress.
The file is located at log.txt.
Installing assembly 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_8.0.13.0__c5687fc88969c44d\MySql.Data.dll'.
Affected parameters are:
logtoconsole = true
logfile = log.txt
assemblypath = C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_8.0.13.0__c5687fc88969c44d\MySql.Data.dll
An exception occurred while trying to find the installers in the C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_8.0.13.0__c5687fc88969c44d\MySql.Data.dll assembly.
System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
Aborting installation for C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_8.0.13.0__c5687fc88969c44d\MySql.Data.dll.


Without going in to deep technical details I was able to open the dll in a decompiling tool and it showed that one of its dependancies was missing. The dependency was Google.Protobuf.dll. I found this file in the C:\Program Files (x86)\MySQL\Connector NET 8.0\Assemblies\v4.5.2 directory and installed it in to the GAC using the below command.

c:\>gacutil /I Google.Protobuf.dll

Once that was installed I ran the installer again and it worked. It sounds like the installer has a bug and for some reason in my case it didn't install that dll in the GAC before trying to run the installutil on MySql.Data.dll. May be I had an older version or something that made it think it didn't have to.

Options: ReplyQuote


Subject
Written By
Posted
Re: Connector.Net 8.0.13 install failing
January 15, 2019 03:27PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.