ADO.NET Entity Data Model not creating model
Posted by: Nash Michel
Date: July 17, 2020 02:29PM

Context : I have a mySQL server running in AWS, and am attempting to interface with it via a WinForms application.

I am able to connect to the db with mySQL workbench without issue.

Problem (in sequence to reproduce):

1) Right click project -> Add -> New Item
2) Under the Data category, I choose ADO.NET Entity Data Model
3) EF Designer from Database
4) Here I choose a new connection, the datasource field indicates "MySQL Database (MySQL Data Provider)"
5) I enter the credentials, endpoint, etc, connection succeeds
6)
Here is the problem. It asks what version of the entity framework I would like to use, but instead of active radio buttons stating EF6 or EF5, I am given the following error :

"Your project references the latest version of Entity Framework however, an Entity Framework database provider compatible with this version could not be found for your data connection. If you have already installed a compatible provider, ensure you have rebuilt your project before performing this action. Otherwise, exit this wizard, install a compatible provider, and rebuild your project before performing this action. Learn more about this"

Obviously, one would think the solution is to install an Entity Framework database provider. The problem is I have one installed.

Things I have done to attempt to fix this :

1) Re-install Visual Studio 2017
2) Re-install MySQL community, and all associated addons (.net connector and visual studio plugin)

At this point no error message was displayed after hitting next, the dialog box would simply close, and generate a DB connection, but no actual model.

3) Installed all packages made by MySQL
4) Tried almost every combination of packages posted by MySQL
5) Re-installed the connector with the MySQL installer, and rebooted, about 4 times.
6) Used REVO uninstaller to absolutely destroy every single trace of mySQL and Visual Studio 2017 on my computer including registry entries



I have followed every instruction I could find as thoroughly as possible and have spent my entire morning dealing with this issue. At this point I have tried the same thing (nuke studio+mySQL and reinstall) way too many times, and I am now turning to these forums for some advice. I just wanted to use Entity Framework instead of old fashioned writing db context + code stuff myself.

If it matters to know, my Visual Studio installation is on C drive and projects on D but this has never affected anything before. I am on W10.

Options: ReplyQuote


Subject
Written By
Posted
ADO.NET Entity Data Model not creating model
July 17, 2020 02:29PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.