Possible charset problem
Posted by: s.a.w.gooren
Date: January 12, 2005 12:19PM

MySQL 4.0.18a-log, tried both connector/J 3.0.15 and 3.1.6 (both when they had GA status).

Using the commandline client I see 'André', while using JDBC I see 'André'. SHOW VARIABLES shows no difference in character and collation settings between cmdline and JDBC, except for "character_set_results: NULL" while using JDBC.
When setting the same var to NULL on the cmdline client, I still get correct data.

Where should I look?

Tried adding 'useUnicode=true' and 'characterEncoding=UTF-8', and all possible combinations of all these separate factors, without luck.

Options: ReplyQuote

Written By
Possible charset problem
January 12, 2005 12:19PM
January 16, 2005 01:33PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.