Re: Problem solved... BUG?
Posted by: Mark Matthews
Date: February 11, 2005 08:54AM

iam1981 wrote:
> Hi,
>
>
> the problem is solved.
>
> Sun Java Studio Enterprise doesn't work properly
> with CMP related entity beans and neither
> mysql-connector-java-3.1.6 nor
> mysql-connector-java-3.2.0-alpha.
>
> I had to use mysql-connector-java-3.0.11-stable.
>
> I don't know if the problem is located in my
> computer, in the connector itself or in the IDE.
>
> One more issue:
>
> Why the MysqlXADataSource class is only available
> in mysql-connector-java-3.2.0-alpha (under
> development) and mm.mysql-2.0.14 (August 2002)??
> Does the old one works properly?


No, the old one doesn't work, it's just emulation. You can only really have XA if the server supports it. The MySQL server won't support it until 5.0 goes into beta status.

As far as Studio 'losing' foreign keys, we'd need to see a testcase to tell you whether or not it was a JDBC bug. Are all of your tables of 'innodb' type (i.e. the only kind that support foreign keys)?

-Mark

Mark Matthews
Consulting Member Technical Staff - MySQL Enterprise Tools
Oracle
http://www.mysql.com/products/enterprise/monitor.html

Options: ReplyQuote


Subject
Written By
Posted
February 11, 2005 08:37AM
Re: Problem solved... BUG?
February 11, 2005 08:54AM
February 11, 2005 12:44PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.