special charcaters not showing in linux
Posted by: Andy Donovan
Date: March 12, 2005 07:12AM


I have just migrated a J2EE site and mysql database from windows to linux.
One problem is special characters such as 'é' now show as '?'. This is only if they are read from the database. If I hardcode the characters in my JSP, it displays OK. This rules out apache / http causing the problem.

So the problem is somewhere in the mysql side. The database is fine as if I view it from a remote mysql Control Centre, the characters are ok.

I am using mysql-connector-java-2.0.14-bin.jar. Which is what I was using under windows and was working fine.

Yet more bizzare, I have just written a test java program that only connects to the database and selects a column and puts it th stdout. If I run this program on a windows machine, connecting to the remote linux mysql database, the output is ok. If I run the same program on linux I get chinese for the 'é' characters?

Any suggestions?


Options: ReplyQuote

Written By
special charcaters not showing in linux
March 12, 2005 07:12AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.