MySQL Forums
Forum List  »  Connector/JDBC and Java

Re: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '????????????????' at line 1
Posted by: Jason Shu
Date: November 13, 2009 07:25PM

create database with utf-8 character like that:
COLLATE `utf8_general_ci`;

But if your databases exists, perhaps it would be helpful by setting the following varaiables:
SET character_set_client = utf8;
SET character_set_results = utf8;
SET character_set_connection = utf8;

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.