Can't flush hosts
Posted by: Sam
Date: October 25, 2004 07:20AM


I hope someone can help me with this strange issue. I have a website which uses JSP and servlets to connect to a MySQL database via JDBC. It is working on the machine I developed it on but I am having trouble trying to get it to work on other machines.

When the servlet tries to access the database I get an SQLException: "Server configuration denies access to data source".

After installing a later JDBC driver I get a more informative error: "Data source rejected establishment of connection, message from server: "Host 'MY_IP_ADDRESS' is blocked because of many conenction errors. Unblock with 'mysqladmin flush-hosts'"

Now this problem appears everywhere on the web but none of the solutions have resolved my issue. I have tried:

- Granting all privileges to the user
- Flushing the privileges
- Flushing the hosts
- Re-installing MySQL

and a few other things (I've been trying for two days!) but I still get the same error!

Has anyone come accross this before?

I am using Apache Tomcat 4.1 as my webserver, is there a cache that could be causing this?

Thanks in advance.


Options: ReplyQuote

Written By
Can't flush hosts
October 25, 2004 07:20AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.