Re: Connect to MySQL: PacketTooGBigException
Posted by: Filipe Silva
Date: May 09, 2016 10:19AM

You are setting a 'maxAllowedPacket' value too low. The exception is telling you everything you need: you have to increase the 'maxAllowedPacket' value.

As I told you before, if the server's value for 'max_allowed_packet' is good for you, then simply don't set the 'maxAllowedPacket' property in the connection string. If you really want/need to limit the packet size (to a value lower that the server's), you still have to increase the connection property 'maxAllowedPacket' to a reasonable amount, '1048576' is simply not enough.

I hope that helps.

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.