MySQL Forums
Forum List  »  Connector/JDBC and Java

TLSv1.2 support
Posted by: Briag Boivin
Date: September 15, 2016 02:47AM

Hello,

I try to connect on my MysqL server (5.7, recompiled with OpenSSL) with TLSv1.2 (by invalidating TLSv1.1) and it doesn't work. I use mysql-connector-java-5.1.39 with JRE 1.8. I get this following message :

main, handling exception: javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)
main, SEND TLSv1.2 ALERT: fatal, description = handshake_failure

Thanks for advance,

Briag

Options: ReplyQuote


Subject
Written By
Posted
TLSv1.2 support
September 15, 2016 02:47AM
December 02, 2016 02:50AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.