ClassNotFoundException com.mysql.jdbc.Driver
Posted by: Doug Jones
Date: November 26, 2004 10:35AM

I have Mysql installed (4.0.20d-win-noinstall), from the command prompt I can create a database , alter tables and get results. I downloaded the jconnector(3.0.16ga) installed it exactly as it specifies. First by putting the directory holding the com and org subdirectories in the system classpath and my user environment classpath, that didn't work, then I put the .jar file the installation instructions specify to put in the classpath, that didn't work. Then I tried putting the jar file in the java_home/jre/lib/ext folder. That also didn't work I keep getting ClassNotfound exception. I tried "sun.jdbc.odbc.jdbcOdbc.Driver" and it worked once but doesn't work now. I get noSuitableDriver error.
PLease help

Options: ReplyQuote

Written By
ClassNotFoundException com.mysql.jdbc.Driver
November 26, 2004 10:35AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.