Re: move db from mysql 5.6.51 to 8.0.26.
Posted by: Shawn Green
Date: July 08, 2022 10:21AM

You have 3 possible ways to fix this problem

1) upgrade your Connector/J to a build that knows what utf8mb4 is (the most recent build is always recommended as it will also have the most up-to-date security fixes) A list of the most recent builds and the bug fixes that went into creating them: https://dev.mysql.com/doc/relnotes/connector-j/8.0/en/news-8-0-29.html

2) change your server's defaults so that it starts the conversation with a less capable character set (examples: https://stackoverflow.com/questions/43991101/re-introduced-unknown-initial-character-set-index-error )

3) change how you connect to specify a characterEncoding option (examples: https://stackoverflow.com/questions/50855622/unknown-initial-character-set-index-255-received-from-server )

As you may infer from my wording, it would be better for you to update your driver rather than to try to keep using a less secure connection library.

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.