MySQL Forums
Forum List  »  Perl

DBD::MYSQL install fails Solaris 10
Posted by: C S
Date: August 26, 2008 10:39AM

I apologize for the length of this post. But I am running into a road block that I need to resolve quickly. I am sure I am not the only person to have ran into this but I can only find a reference to my specific error that references Solaris 9 and I am trying to install on Solaris 10.

DBD::MYSQL fails on make test on Solaris 10 with the following error. Make completes with no errors.

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00base....................ok 1/6
t/00base....................NOK 2# Failed test 'use DBD::mysql;'
# at t/00base.t line 21.
# Tried to use 'DBD::mysql'.
# Error: Can't load '/admin/site_perl/DB/DBD-mysql-4.008/blib/arch/auto/DBD/mysql/' for module DBD::mysql: perl: fatal: relocation error: file /admin/site_perl/DB/DBD-mysql-4.008/blib/arch/auto/DBD/mysql/ symbol mysql_real_escape_string: referenced symbol not found at /usr/perl5/5.8.4/lib/sun4-solaris-64int/ line 230.
# at (eval 5) line 2
# Compilation failed in require at (eval 5) line 2.
# BEGIN failed--compilation aborted at (eval 5) line 2.
FAILED--Further testing stopped: Unable to load DBD::mysql
*** Error code 255
make: Fatal error: Command failed for target `test_dynamic'

Here is my initial build command:

perl Makefile.PL --testuser=user --testpassword=pw --cflags="-I/opt/mysql/mysql/include -D_FORTEC_ -m64 --libs="-L/opt/mysql/mysql/lib -lmysqlclient -lz -lposix4 -lresolv -lgen -lsocket -lnsl -lm"

I installed the DBI-1.607 module and installed with no errors

Here are some pertinent details of my install.

SunOS 5.10 Generic_127127-11 sun4u sparc SUNW,Sun-Fire-880

Perl –v
This is perl, v5.8.4 built for sun4-solaris-64int

Mysql –v

Server version: 5.0.67 MySQL Community Server (GPL)


ldd => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/ => /lib/

Some things I have tried.

I have tried building against static libraries only.
perl Makefile.PL --testuser=user --testpassword=pw --libs="-L/tmp/mysql-static -lmysqlclient"

I have tried copying my libmysqlclient libs to /usr/lib and making sure all other versions of libmysqlclient have been removed. The current version is

I am at a loss and any help is greatly appreciated.

Edited 1 time(s). Last edit at 08/26/2008 10:42AM by Capstone Solutions.

Options: ReplyQuote

Written By
DBD::MYSQL install fails Solaris 10
August 26, 2008 10:39AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.