MySQL Forums
Forum List  »  Perl

DBT2 (v 0.40) - MySQL 5.0.67 - Amazon EC2
Posted by: Ahsan Hussain
Date: February 12, 2009 02:07AM

So I am trying to run the DBT2 benchmark on MySQL in an amazon cloud. But every time I increase the buffer pool size (/etc/my.cnf - innodb_buffer_pool_size), I do not get ANY performance improvement. I figured that this may be because I am not "stressing" the system enough. As a result, i tried to play with the parameters on the test script. I have the following questions:

1. Is there a manual for understanding the parameters for anywhere? I do not know what terminals, number of warehouses (scale factor), number of connections mean.

2. So everything runs fine when I run this configuratino of the

./ -c 20 -t 20 -d 300 -w 30 -u root

Once I increase the number of warehouses or scale factor (-w option) by a huge amount, I get the errors below. Here the number of connections (-c) is 20, the number of terminals is 200, the scale factor is 20 whereas the duration 3600 s.

[root@domU-12-31-39-01-64-21:~/dbt2-0.40/scripts] ./ -c 20 -t 200 -d 3600 -w 20 -u root
MySQL pid file 'yes/var/' does not exist.
MySQL was not stopped, if it was running.
/root/dbt2-0.40/scripts/mysql/ illegal option -- p
* DBT-2 test for mysql started
* *
* Results can be found in output/8 directory
* *
* Test consists of 3 stages: *
* *
* 1. Start of client to create pool of databases connections *
* 2. Start of driver to emulate terminals and transactions generation *
* 3. Processing of results *
* *

DURATION OF TEST (in sec): 3600
1 client stared every 1000 millisecond(s)

Stage 1. Starting up client...
Sleeping 21 seconds

Stage 2. Starting up driver...
1000 threads started per millisecond
estimated rampup time: Sleeping 210 seconds
estimated rampup time has elapsed
estimated steady state time: Sleeping 3600 seconds

Stage 3. Processing of results...
Killing client...
MySQL pid file 'yes/var/' does not exist.
MySQL was not stopped, if it was running.
./ line 548: [: -eq: unary operator expected
./ line 461: 17061 Terminated ${abs_top_srcdir}/src/client ${CLIENT_COMMAND_ARGS} >${OUTPUT_DIR}/client.out 2>&1
./ line 498: 17109 Terminated ${abs_top_srcdir}/src/driver ${DRIVER_COMMAND_ARGS} >${OUTPUT_DIR}/driver.out 2>&1
Use of uninitialized value in subtraction (-) at /usr/lib/perl5/site_perl/5.8.8/Test/Parser/ line 346.
Use of uninitialized value in subtraction (-) at /usr/lib/perl5/site_perl/5.8.8/Test/Parser/ line 349.
Use of uninitialized value in subtraction (-) at /usr/lib/perl5/site_perl/5.8.8/Test/Parser/ line 351.
Illegal division by zero at /usr/lib/perl5/site_perl/5.8.8/Test/Parser/ line 402.
chmod: cannot access `/root/dbt2-0.40/scripts/output/8/db/log': No such file or directory
Test completed.
Results are in: /root/dbt2-0.40/scripts/output/8

PARSE - Setting total transaction count to 0.
STATS - The total transaction count is: 0.

The total transaction count (is what I print myself in order to debug) goes to 0 which results in a division by zero in file. What am doing wrong here? Unfortunately I do not understand the enough to say whether the parameters that I'm using are the right ones.

Any help with this would be highly appreciated.

Options: ReplyQuote

Written By
DBT2 (v 0.40) - MySQL 5.0.67 - Amazon EC2
February 12, 2009 02:07AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.