MySQL Forums
Forum List  »  Perl

Re: MySQL, Solaris 9 and DBD::mysql
Posted by: Zoloft 2001
Date: January 11, 2005 09:13PM

I'm running Solaris 9 x86 04/04. It's all patched up with current (as of Jan. 4) source installs of gcc, make, and perl.

After running into the same or a similar problem, and thrashing about on Goggle, MySQL, and perl groups and forums, I decided to just copy my mysql library files to: /usr/local/lib and my mysql include files to: /usr/local/include.

I then ran…

# perl -MCPAN -e shell

CPAN> install Bundle::DBD::mysql

...and it worked!

So, I concluded that my PATH and LD_LIBRARY_PATH were totally jacked up and not allowing perl, make, gcc, ld or something else to see my libs and includes.

Just for kicks, I may rebuild and do it all over with Solaris 9 x86 09/04 or even that wild, new Solaris 10. If I can duplicate the results, then it’s probably safe to say that it’s just a matter of having a working path to everything.

Good luck. Post here so we know how it worked out.

Options: ReplyQuote


Subject
Written By
Posted
Re: MySQL, Solaris 9 and DBD::mysql
January 11, 2005 09:13PM
June 05, 2006 10:49AM
June 05, 2006 01:10PM
March 07, 2005 12:57PM
March 07, 2005 12:58PM
February 14, 2006 10:32AM
October 24, 2007 08:59AM
November 17, 2007 07:58PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.