MySQL Forums
Forum List  »  Perl

Re: MySQL, Solaris 9 and DBD::mysql
Posted by: carlo reyes
Date: June 02, 2006 02:58PM

I tried including the xcode entry when I run perl Makefile.PL, but I still get thesame result. I even tried xarch=v9a and xarch=v9b entry in mysql_config, but I get thesame error. I'm stuck at this point, any suggestion will be appreciated. :(

# perl Makefile.PL --cflags="`mysql_config --cflags` -xcode=abs64"
I will use the following settings for compiling and testing:

cflags (User's choice) = -I/opt/mysql/mysql/include -xO3 -mt -D_FORTEC_ -xarch=v9 -xcode=abs64
embedded (mysql_config ) =
libs (mysql_config ) = -xarch=v9 -L/opt/mysql/mysql/lib -lmysqlclient -lz -lposix4 -lcrypt -lgen -lsocket -lnsl -lm
mysql_config (guessed ) = mysql_config
nocatchstderr (default ) = 0
nofoundrows (default ) = 0
ssl (guessed ) = 0
testdb (default ) = test
testhost (default ) =
testpassword (default ) =
testsocket (default ) =
testuser (default ) =

To change these settings, see 'perl Makefile.PL --help' and
'perldoc INSTALL'.

Unrecognized argument in LIBS ignored: '-xarch=v9'
Using DBI 1.50 (for perl 5.008008 on sun4-solaris) installed in /usr/local/lib/perl5/site_perl/5.8.8/sun4-solaris/auto/DBI/
Writing Makefile for DBD::mysql

Options: ReplyQuote

Written By
Re: MySQL, Solaris 9 and DBD::mysql
June 02, 2006 02:58PM
June 05, 2006 10:49AM
June 05, 2006 01:10PM
March 07, 2005 12:57PM
March 07, 2005 12:58PM
February 14, 2006 10:32AM
October 24, 2007 08:59AM
November 17, 2007 07:58PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.