MySQL Forums
Forum List  »  French

Mysqlhotcopy / restauration
Posted by: Emmanuel Bourgeois
Date: January 28, 2009 03:23AM

Bonjour,

j'ai un script qui me fait un backup journalier des bases mysql, en utilisant un mysqlhotcopy.

je viens de tester la restauration, et visiblement quelque chose se passe mal, car après la restauration l'application fonctionne comme si la base était vide.

Mon script de copie :
mysqlhotcopy dolibarr /backup-sql -u root -p xxxxxxxx --allowold

pour restaurer j'ai fait :
sudo /etc/init.d/mysql stop
sudo mv /var/lib/mysql/dolibarr /var/lib/mysql/dolibarr.old --> au cas ou...
sudo mv /backup-sql/dolibarr /var/lib/mysql/dolibarr --> je deplace la copie
sudo /etc/init.d/mysql start
sudo /etc/init.d/apache2 restart --> au cas ou...

l'application est "dolibarr"

qu'est-ce que j'ai rate ?

Pour revenir a l'ancienne version (avant restauration) j'ai fait :
sudo /etc/init.d/mysql stop
sudo mv /var/lib/mysql/dolibarr.old /var/lib/mysql/dolibarr
sudo /etc/init.d/mysql start
sudo /etc/init.d/apache2 restart

Et la, tout re-fonctionne comme avant la restauration.

merci,
Manu.



Edited 1 time(s). Last edit at 01/28/2009 03:27AM by Emmanuel Bourgeois.

Options: ReplyQuote


Subject
Views
Written By
Posted
Mysqlhotcopy / restauration
6793
January 28, 2009 03:23AM
3157
January 28, 2009 07:10AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.