MySQL Forums
Forum List  »  Russian

mysqld.exe suddenly can't start, the "memory could not be read" error
Posted by: Eugen G.
Date: October 02, 2010 02:43PM

Hello,

My setup is: Windows XP SP3 with MySQL Server 5.1 Essential (using it for radio broadcasting via SAM Broadcaster).

Every time, after about 40 days of system up-time, mysqld.exe crashes for no reason.

I tried to restart the process, and while i was able to stop it using net stop mysql command, i was never able to start it back using the net start mysql command.
I am getting a typical Windows error message about application error and memory that could not be read.
A simple computer restart did not help neither, the mysqld.exe refuses to start, giving the same error message.

The ibdata1 database file is fine, because after a clean Windows and MySQL installation i have manually replaced the new file with the old one and everything is still working fine.

There must something going wrong with mysqld.exe service or file.

Here is the screen shot of the classic error message, but unfortunately it is in Russian. I guess anyone can recognize the message about memory that could not be read.


Has anyone ever encountered an issue like that? I am totally down with this...

Options: ReplyQuote


Subject
Views
Written By
Posted
mysqld.exe suddenly can't start, the "memory could not be read" error
7465
October 02, 2010 02:43PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.