MySQL Forums
Forum List  »  Other Migration

Error trying to migrate from 3.23.51 to 5.1.66
Posted by: Gerald Livingston
Date: February 15, 2013 06:29PM

NOTE: bbcode doesn't seem to be turned on here so the "code" blocks aren't clean.

Hello,

I'm trying to migrate from an OLD running 3.23.51 server to a new(er) 5.1.66 server. I've gone through the following steps:

On the old server:

mysqldump -p --add-drop-table --add-locks --all --quick --lock-tables radiator > radiator.sql

The .sql created is a bit over 2GB

Then I scp the .sql to the new server

On the new server:

iconv -f latin1 -t utf8 < radiator.sql > radiator-utf8.sql

sed -e "/auto_increment/ s/DEFAULT '0'//" radiator-utf8.sql > radiator-utf8-filt.sql

I then DROP the radiator database to ensure it doesn't exist and I run

mysql -p radiator <radiator-utf8-filt.sql

When I run it I get this error:

mysql  Ver 14.14 Distrib 5.1.66, for debian-linux-gnu (i486) using readline 6.1
root@radius1:~# mysql -p radiator <radiator-utf8-filt.sql 
Enter password: 
ERROR 1064 (42000) at line 4: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-------------------------------------------------------

DROP TABLE IF EXIS' at line 1

-------------------------------------------------------

This is the first part of the .sql file

-------------------------------------------------------

-- MySQL dump 8.22
--
-- Host: localhost    Database: radiator
---------------------------------------------------------
-- Server version       3.23.51

--
-- Table structure for table 'ACCOUNTING'
--

DROP TABLE IF EXISTS ACCOUNTING;
CREATE TABLE ACCOUNTING (
  USERNAME char(50) NOT NULL default '',
  TIME_STAMP int(11) default NULL,
  ACCTSTATUSTYPE char(10) default NULL,
  ACCTDELAYTIME int(11) default NULL,
  ACCTINPUTOCTETS int(11) default NULL,
  ACCTOUTPUTOCTETS int(11) default NULL,
  ACCTSESSIONID char(30) default NULL,
  ACCTSESSIONTIME int(11) default NULL,
  ACCTTERMINATECAUSE int(11) default NULL,
  NASIDENTIFIER char(50) default NULL,
  NASPORT int(11) default NULL,
  FRAMEDIPADDRESS char(22) default NULL,
  KEY ACCOUNTING_I (USERNAME)
) TYPE=MyISAM;

Note that it seems to stop reading the first actual command line part way through. I don't understand what is happening at all.

Ideas?

Options: ReplyQuote


Subject
Views
Written By
Posted
Error trying to migrate from 3.23.51 to 5.1.66
5770
February 15, 2013 06:29PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.