MySQL Forums
Forum List  »  New in 4.1: Subqueries

Re: #HY000Host 'XXX' is not allowed to connect to this MySQL server
Posted by: simon smith
Date: February 17, 2006 09:06AM

hi
when i did this it worked but it keep soming up with this
4 4.1.16#9h!hiVT",¢K6h+=2~G&(7xÿBad handshake
and when i click refresh it alway come up.

can you sort this out

thanks



epico saga wrote:
> I have a problem connecting remotely to my MySQL
> Server from my windows xp home edition client
> computer. But thank God I got a solution to the
> problem. here's how I did it.
>
> My OS is Fedora Core 3 and my Database server is
> MySQL Max 5.0.15
>
> First, I created a database using CREATE DATABASE
> <database name>;
>
> mysql> create database <database name>;
>
> (Note: the create database <database name>
> command
> can be type at any case, the <> is not
> included
> I just want to emphasize that it is a database
> name)
>
> Second, I execute the GRANT command
>
> mysql> grant all on databasename.* to
> your_mysql_user@remote_host identified by
> 'your_mysql_user_password';
>
> the .* after the databasename is needed. don't
> omit it.
>
> replace your_mysql_user to your real mysql user
> account which is in my case is root.
>
> replace remote_host to your real remote hostname
> or ip address.
>
> replace your_mysql_user_password to the password
> you want to use on accessing your database. The
> single quotation at the beginning and at the end
> of the password is needed. Don't omit it.
>
>
> Third, try to connect from your remote client to
> your remote MySQL server, and vilola!!! you are
> done.
>
> Hope this will help a lot.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: #HY000Host 'XXX' is not allowed to connect to this MySQL server
18405
February 17, 2006 09:06AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.