MySQL Forums
Forum List  »  Stored Procedures

Re: Error: "Procedure X can't return a result set in the given context"
Posted by: Lawrence Holtsclaw
Date: October 18, 2005 08:35AM

I really hate to tell you this, but the IN absolutely must have everything to do with it because that was literally the only difference between what worked and what didn't. In case it helps, this procedure is three-levels deep in calls (Procedure A -> Procedure B -> Procedure C). It was the only procedure without explicit IN declarations (a typo on my part that I initially ignored). I changed it solely beause I had already tried about everything else but that.

I could send you the procedures but you'd be unable to test drive it without a couple of large tables and a couple of dynamically loaded UDF's. Considering someone else has supplied an extremely terse test case, I'll assume that's not neccessary. Before you ask, I bypassed the UDF calls during testing without effect so the use of them is not relevant.

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.