MySQL Forums
Forum List  »  Triggers

After insert trigger seems to run before insert
Posted by: Alan Stead
Date: August 24, 2015 12:06AM

I created an after insert trigger which uses sys_exec to send a dbus system message to my QT app to tell it to update its data. The QT app then runs a select statement on the table and fills a drop down list. I turned on logging in mysql and it appears to be running in order:
- insert statement
- calling sys_exec
- select statement

However in the QT app, I don't see the new record. If I run it again, then I see the record I previously inserted. I tried adding some delays in the trigger, and tried calling the sys_exec statement twice, but I still get the same result.

Any input would be appreciated.
Thanks!

Options: ReplyQuote


Subject
Views
Written By
Posted
After insert trigger seems to run before insert
1794
August 24, 2015 12:06AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.