Skip navigation links

MySQL Forums :: Ruby :: Help for gem install sql errors...


Advanced Search

Help for gem install sql errors...
Posted by: Andrew Ting ()
Date: December 21, 2009 08:19AM

Hi,

I downloaded & double clicked 3 files to install mysql 5.1 for MacOS, but i get the following errors, can someone advise please?

Thanks!

Ad

======================================================

sudo gem install mysql -- --with-mysql-config=/path/to/mysql_config
Building native extensions. This could take a while...
ERROR: Error installing mysql:
ERROR: Failed to build gem native extension.
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb --with-mysql-config=/path/to/mysql_config
extconf.rb:10: command not found: /path/to/mysql_config --cflags
Gem files will remain installed in /Library/Ruby/Gems/1.8/gems/mysql-2.8.1 for inspection.
Results logged to /Library/Ruby/Gems/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out


And when i ran one ruby program :-


$ ruby blog.rb
/Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/adapters/mysql.rb:2: LoadError: require 'mysql' did not define Mysql::CLIENT_MULTI_RESULTS! (Sequel::AdapterNotFound)
You are probably using the pure ruby mysql.rb driver,
which Sequel does not support. You need to install
the C based adapter, and make sure that the mysql.so
file is loaded instead of the mysql.rb file.
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/core.rb:165:in `require'
from /Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/core.rb:165:in `each'
from /Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/core.rb:165:in `require'
from /Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/database.rb:111:in `adapter_class'
from /Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/database.rb:140:in `connect'
from /Library/Ruby/Gems/1.8/gems/sequel-3.7.0/lib/sequel/core.rb:100:in `connect'
from ./data/init.rb:7
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from blog.rb:7

Options: ReplyQuote


Subject Written By Posted
Help for gem install sql errors... Andrew Ting 12/21/2009 08:19AM
Re: Help for gem install sql errors... mike montagne 03/21/2010 09:33AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.