Skip navigation links

MySQL Forums :: PHP :: Headers and client library minor version mismatch


Advanced Search

Headers and client library minor version mismatch
Posted by: Tom Pitcher ()
Date: November 07, 2009 07:31AM

I'm receiving the following error when attempting to run methods from the mysqli library:

Warning: mysqli::real_connect() [mysqli.real-connect]: Headers and client library minor version mismatch. Headers:50075 Library:50131 in /file/path line #

I built PHP from source, and installed MySQL from the Ubuntu repositories. I've tried to downgrade the server and client from 5.1 to 5.0, but it won't let me due to some configuration error involved with the downgrade. Does anyone happen to know what packages may be conflicting to give that version error, or is there something else causing it?

Thanks in advance.

Options: ReplyQuote


Subject Written By Posted
Headers and client library minor version mismatch Tom Pitcher 11/07/2009 07:31AM
Re: Headers and client library minor version mismatch Tom Pitcher 11/08/2009 07:59AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.