Skip navigation links

MySQL Forums :: PHP :: Change Collation


Advanced Search

Re: Change Collation
Posted by: PeterSwiss ()
Date: February 27, 2006 01:07PM

I believe, that in my case, as the "export" command from phpmyAdmin delivers "DEFAULT CHARSET latin1" (no collation) ,therefore in "import" from phpmyAdmin I have "DEFAULT CHARSET latin1, swedish collation", because swedish is default to latin1, instead of the default database collation. That is database default collation is not honored if characterset is given in "import".

I agree with Georg Richter that for a large database as is the case of the initial poster LordJohnny, the better steps are, given a bit more knowledge,
(1) SHOW TABLES
this delivers a plain list of all tables in the data base
(2) create a file with many ALTER TABLE xxx DEFAULT CHARSET latin1 COLLATE latin1_mylanguage_ci;
(3) run that file.

Options: ReplyQuote


Subject Written By Posted
Change Collation Lordjohnny 12/14/2005 01:36PM
Re: Change Collation PeterSwiss 02/25/2006 02:04PM
Re: Change Collation Georg Richter 02/26/2006 04:10AM
Re: Change Collation PeterSwiss 02/26/2006 04:50AM
Re: Change Collation PeterSwiss 02/26/2006 05:20AM
Re: Change Collation Georg Richter 02/26/2006 06:09AM
Re: Change Collation PeterSwiss 02/26/2006 06:26AM
Re: Change Collation Ken Lyle 03/24/2007 10:31AM
Re: Change Collation Georg Richter 02/26/2006 04:12AM
Re: Change Collation PeterSwiss 02/27/2006 01:07PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.