MySQL Forums :: Newbie :: load data character set question


Advanced Search

load data character set question
Posted by: R Menon ()
Date: March 28, 2009 02:19PM

Mysql version: set session character_set_database=utf8
OS: Windows Vista

I have a file that when loaded with the load data infile command - fails with the error:
ERROR: Incorrect string value: '\xE2\xA2\xE3?\xE2\xB4...' for column 'column' at row 1

the file gets successfully loaded if i use the following command at session level:

set session character_set_database=latin1.

This is needed since at database level this parameter is set to utf8.

Now, I would have thought if i specify the character set (of latin1)in the load command itself, it would have worked - it does not and fails with the same error.

Is this a known bug or am I missing something?

Thank you!
Menon

Options: ReplyQuote


Subject Written By Posted
load data character set question R Menon 03/28/2009 02:19PM
Re: load data character set question Rick James 03/29/2009 08:23PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.