MySQL Forums
Forum List  »  Newbie

Problem launching MySQL
Posted by: Jugger Naut
Date: October 28, 2013 01:03AM

Hi there!!

First of all, let you know that I´m Spanish and my computer is in that language, so I get the error texts in that language too. I´ll try to translate the best I can (I also posted in the Spanish forum, but this one seems to be way more active than that)
Thank you for your understanding!!

I´m trying to make my first page in Wordpress (obviously with MySQL). I have worked all day long, closed Apache & MySQL properly and restated my computer. When I tried to restart Wordpress with XAMPP, I get ths error back:
Error stablishing DataBase connection

When I tried to start http://localhost/phpmyadmin, I got this error message:
Access denied
#2002 – Can not stablish a connection because the destination equipmen refused that connection.
Ther server is not answering (or the local place at the MySQL Server is not properly configured)

When I checked the error log in MySQL I got:
2013-10-27 05:52:10 4180 [Note] Plugin 'FEDERATED' is disabled.
2013-10-27 05:52:10 15f4 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2013-10-27 05:52:10 4180 [Note] InnoDB: The InnoDB memory heap is disabled
2013-10-27 05:52:10 4180 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2013-10-27 05:52:10 4180 [Note] InnoDB: Compressed tables use zlib 1.2.3
2013-10-27 05:52:10 4180 [Note] InnoDB: Not using CPU crc32 instructions
2013-10-27 05:52:10 4180 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2013-10-27 05:52:10 4180 [Note] InnoDB: Completed initialization of buffer pool
2013-10-27 05:52:10 4180 [Note] InnoDB: Highest supported file format is Barracuda.
2013-10-27 05:52:10 4180 [Note] InnoDB: The log sequence numbers 0 and 0 in ibdata files do not match the log sequence number 2887567 in the ib_logfiles!
2013-10-27 05:52:10 4180 [Note] InnoDB: Database was not shutdown normally!
2013-10-27 05:52:10 4180 [Note] InnoDB: Starting crash recovery.
2013-10-27 05:52:10 4180 [Note] InnoDB: Reading tablespace information from the .ibd files...
2013-10-27 05:52:10 4180 [ERROR] InnoDB: Attempted to open a previously opened tablespace. Previous tablespace mysql/slave_relay_log_info uses space ID: 3 at filepath: .\mysql\slave_relay_log_info.ibd. Cannot open tablespace wordpress/wp_terms which uses space ID: 3 at filepath: .\wordpress\wp_terms.ibd
InnoDB: Error: could not open single-table tablespace file .\wordpress\wp_terms.ibd
InnoDB: We do not continue the crash recovery, because the table may become
InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.
InnoDB: To fix the problem and start mysqld:
InnoDB: 1) If there is a permission problem in the file and mysqld cannot
InnoDB: open the file, you should modify the permissions.
InnoDB: 2) If the table is not needed, or you can restore it from a backup,
InnoDB: then you can remove the .ibd file, and InnoDB will do a normal
InnoDB: crash recovery and ignore that table.
InnoDB: 3) If the file system or the disk is broken, and you cannot remove
InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf
InnoDB: and force InnoDB to continue crash recovery here.

Ihave checked several Webpages with posible solutios, these are the ones I already tried at not worked:

$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['host'] = '';

In my case, that line was already as '' and IT DOES NOT WORK (just in case, I tried the other way…. Change to localhost.... and it doesn´t work either)


in my "" file I had:
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';

I have changed to:
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';



I have seen that in the error log there is a problema trying to open the table in ".\wordpress\wp_terms.ibd"
I have the file "\wp_terms.ibd" in the folder ".\wp\"
I tried to change the name of the folder from "\wp\" to " "\wordpress\" (because I don´t know where to change the order in MySQL to change one or the other).


This has happened to me in the past days, always when I restart my computer. I fixed it uninstalling XAMPP and reinstalling it... but I don´t want to do it now because I´m afraid to lose the work I have done with the page I was preparing

Any idea???

Thank you very much in advance!!!!

Options: ReplyQuote

Written By
Problem launching MySQL
October 28, 2013 01:03AM
October 28, 2013 12:42PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.