MySQL Forums
Forum List  »  Ruby

mysql installation errors
Posted by: Nivedita Chamarthy
Date: June 16, 2010 03:59PM

Hey I am a newbie to mysql and ruby on rails frame work. I have installed mysql 5.1.47. it worked properly. But when I wanted to use it in rails frame work, by running rails command rake db:migrate,after setting up the database, I am not able to execute it. The error I got was
rake aborted!
Access denied for user 'root'@'localhost' (using password : NO)

But I had set the password while installing and accessed mysql database without connecting to rails.

And also, after running the rails command "rake db:migrate", I am not able to access even the mysql database alone. When i attempted to run mysql from command prompt, I was not able to get access. The error I got was
ERROR 1045 (28000) : Access denied for user 'ODBC'@'localhost' (using password : NO)
I tried starting mysql with mysql -u root -p
then I got the prompt to enter password
after entering the password, i got the error
"Access denied for user 'ODBC'@'localhost' (using password : Yes)"

I dont know y this error is coming still, after the password is been set.
Please help me out. I am so confused and no idea of fixing this error. And moreover I have to rush in getting rails frame work with mysql installed, as my project due is coming soon.
Any help is appreciated.

Thanks in Advance !!

Options: ReplyQuote

Written By
mysql installation errors
June 16, 2010 03:59PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.