MySQL Forums
Forum List  »  MySQL Workbench

Integrating Workbench python.exe into PyCharm fails
Posted by: Karsten Wutzke
Date: June 10, 2023 01:30AM

Hello all.

I have a plugin written in Python 2 that has been laying around for ~2 years.

I started installing MySQL Workbench on my new computer and noticed that my plugin isn't working anymore, that is, having installed the plugin the way I used to makes MySQL Workbench crash.

I then installed JetBrains PyCharm, which fails to integrate the WB internal python.exe.

I posted to the JetBrains forums here:

https://intellij-support.jetbrains.com/hc/en-us/community/posts/11892382804882-Integrating-MySQL-Workbench-Python-interpreter-fails

Here you can see what PyCharm spits out as error messages (see screenshots there):

"Cannot set up a Python SDK at (C:\Program Files\MySQL\MySQL Workbench 8.0 CE\python.exe). The SDK seems invalid."

and

"Fatal Python error: initfsencoding: unable to load the file system codec
ModuleNotFoundError: No module named 'encodings'

Current thread: blabla...:"

The JB representative hinted that he gets the same error, quote:

"I have installed MySQL Workbench 8.0.33 and have the same issue when I run python.exe outside the IDE, so it seems to be an issue with their Python distribution."

Will the WB fix this (anytime soon) or what's the desired solution here?

I could fiddle with the Python interpreter with myself, but I think this is not the long-term desired solution here (if it works at all).

Comments (from the team) welcome.

Thanks

Options: ReplyQuote


Subject
Views
Written By
Posted
Integrating Workbench python.exe into PyCharm fails
371
June 10, 2023 01:30AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.