MySQL Forums
Forum List  »  Newbie

1045: Access denied for user 'root@localhost' (using password:NO).
Posted by: Alice Smith
Date: November 06, 2012 03:12PM

Hi all,
I am new to MySQL and just started using the MySQL Workbench to create a new server instance (also tried connecting to the existing server, Local MySQL55). When I do this, I get the error "Access denied for user 'root@localhost' (using password:NO)." (or YES) depending on if I tried a password or not. I have tried using no password, and password and mySQL passwords. I am following the 4. Getting Started Tutorial from the Doc Library.

Here is the detailed information:
MySQL Server 5.5
MySQL Workbench 5.2 CE

Troubleshooting steps:
- Firewall is off
- tried using the --skip-networking and --skip-grant-table options when launching mysql from the command line -> Both options are not recognized..
- restarted computer
- tried right-clicking the mySQL workbench and running as admin, it would not launch

Note: i am remoted into the computer running the SQL server, I googled to see if this was an issue and couldn't find anything. This is a fresh install of mySQL server & workbench.

Any suggestions? Thanks!

Options: ReplyQuote

Written By
1045: Access denied for user 'root@localhost' (using password:NO).
November 06, 2012 03:12PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.