Hebrew
Posted by: Ohad Raz
Date: February 19, 2005 03:58PM

Hello,

I am working with Toad for MySql, and I just love MySql with this easy to use GUI!!!
However, I am facing some troubles.
My problem is with Hebrew characters.
When I insert columns with hebrew letter, they are turning into question marks (?).
I thought that maybe it is Toad's fault, so I tried using the MySql command-line.
But now I cannot not write hebrew at all, I just get Gibrish. It seems that there is no hebrew support for DOS in Win XP (I guess Mr. Gates though there are no more applications using DOS).
I searched the net for some tips, but I could not found any solution.

Some details:
OS: Win XP SP2.
MySql ver: 4.1.10-nt.
The characters variables:
+--------------------------+-------------------------------------------+
| Variable_name | Value |
+--------------------------+-------------------------------------------+
| character_set_client | latin1 |
| character_set_connection | latin1 |
| character_set_database | hebrew |
| character_set_results | latin1 |
| character_set_server | hebrew |
| character_set_system | utf8 |
| character_sets_dir | D:\MySQL\MySQL Server 4.1\share\charsets/ |
+--------------------------+-------------------------------------------+

I tought maybe changing these values all to "hebrew will do the trick, but...
It does not let me changing the character_set_system.
Tried to change all the rest to "hebrew" (using set ....='hebrew'), and then tried to open MySql again, but it got back to this status.

Anyone has any ideas?...
I would appreciate any help.

Kind regards,
Ohad.

Options: ReplyQuote


Subject
Views
Written By
Posted
Hebrew
2997
February 19, 2005 03:58PM
1930
May 07, 2005 08:50AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.