Migration Error - Unable to reverse engineer
Posted by: Steven Wheeler
Date: May 15, 2012 07:41PM

Hi All,

Please bear with me, I'm rather new to all of this... Its a learning curve I've just started.

I'm trying to migrate a rather large table (~5gb) from a live production server to my test box. Every table on the database will migrate fine apart from one. Error from message log is as follows:

The schema could not be reverse engineered (error: 0).
ReverseEngineeringMysqlJdbc.reverseEngineer :The function ReverseEngineeringMysql:reverseEngineer() returned the following error:
Could not execute SHOW CREATE TABLE statement.
com.mysql.grt.Grt.callGrtFunction(Unknown Source)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
java.lang.reflect.Method.invoke(Unknown Source)
com.mysql.grt.Grt.callModuleFunction(Unknown Source)

I've tried to repair the table but to no avail... It was a full 12 hour reindex/rebuild.
It was migrating once before, but the target ran out of space and since I've never been able to get it running again. I have tried to do a manual backup and then restore on the test server but it also failed.

Any ideas would be greatly appreciated.


Options: ReplyQuote

Written By
Migration Error - Unable to reverse engineer
May 15, 2012 07:41PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.