MySQL Forums
Forum List  »  Full-Text Search

MyIsam table won't allow full text indexes
Posted by: Ian Cummings
Date: February 06, 2009 06:01PM

I have a MyIsam table to which I'm trying to add a full text index. I'm getting an error back "The used table type doesn't support FULLTEXT indexes" even though I'm using a MyIsam table.

Here's the short create table script:

use demo_MyIsam;

DROP TABLE IF EXISTS yellow;

CREATE TABLE yellow (
BusinessName varchar(64),

TileX int(11),
TileY int(11),
TileYHashKey int(11),

INDEX TileXIndex (TileX),
INDEX TileYIndex (TileY),

FULLTEXT INDEX BusinessNameIndex (BusinessName)

)

engine = MYISAM

partition by range (TileX)

subpartition by hash (TileYHashKey) subpartitions 25

(

partition p1 values less than (400),
partition p2 values less than (450),
partition p3 values less than (500),
partition p4 values less than (550),
partition p5 values less than (600),

partition p27 values less than maxvalue
);

If I take out the fulltext index line it works correctly, and I can see that it really does create a MyIsam table. Show table status gives

'yellow', 'MyISAM', 10, 'Dynamic', 0, 1, 0, 0, 153600, 0, , '2009-02-06 18:57:05', '2009-02-06 18:57:05', '', 'latin1_swedish_ci', , 'partitioned', ''

I tried several things, none of which worked
1) Setting default engine in my.ini to MYISAM
2) Creating the index after the table with create fulltext index BusinessNameIndex on Yellow (BusinessName);
3) Using ALTER TABLE Yellow ENGINE = MyISAM; then trying to create the table

I'm using the latest version, 5.1.30-community

So how do I fix this? Thanks in advance for your help.

Options: ReplyQuote


Subject
Views
Written By
Posted
MyIsam table won't allow full text indexes
5203
February 06, 2009 06:01PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.