MySQL Forums
Forum List  »  Install & Repo

Can't get init_connect='AUTOCOMMIT=0' to work
Posted by: Scott Mills
Date: August 27, 2004 10:08AM

Hi all,

I've got 4.1.3 installed on Linux.. everything fine so far except for getting the init_connect string to work.

I followed the instructions on
http://dev.mysql.com/doc/mysql/en/Server_system_variables.html

and added the below line to my '/etc/my.cnf' file under [mysqld]:
init_connect='SET AUTOCOMMIT=0'

When I restart the server and start mysql, I can see that the init_connect was read:
mysql> select @@init_connect;
+--------------------+
| @@init_connect |
+--------------------+
| SET AUTOCOMMIT=0|
+--------------------+

However, the Autocommit variable is still 1!
mysql> select @@AUTOCOMMIT;
+-----------------+
| @@AUTOCOMMIT|
+-----------------+
| 1|
+-----------------+

Anyone seen this before or know what's wrong??

Thx in advance,
Scott.

Options: ReplyQuote


Subject
Written By
Posted
Can't get init_connect='AUTOCOMMIT=0' to work
August 27, 2004 10:08AM


Sorry, you can't reply to this topic. It has been closed.
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.