MySQL Forums
Forum List  »  Install & Repo

Table '<table>' is read only
Posted by: steven godber
Date: September 09, 2004 02:08PM

i ftp'd a copy of /var/lib/mysql to safety before rebuilding my apache server after suspected security leak. when i came to put them back i find that my php scripts are unable to write to mysql. i get the message: Table '<table>' is read only. i went directly to mysql and tried to delete all records from another table in the same database but recieved the same message. i have regranted permissions on the database thinking they might have got lost somehow and although no errors were reported the changes have had no effect. i have tried mysqlcheck and myisamchk but to absolutely no avail (although i admit to not totally knowing what i was doing). i tried to drop the table and rebuild it but get an 'error on delete... (Errcode: 13)' message. i really hope someone can help me with this because i can find nothing in the literature about whats going on here and how to stop it. i don't really want to reinstall mysql..
thanks to anyone who can help

Options: ReplyQuote

Written By
Table '<table>' is read only
September 09, 2004 02:08PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.