MySQL Forums
Forum List  »  Install & Repo

A configuration problem
Posted by: Denver Mcanally
Date: October 25, 2004 03:14PM

Hello everyone,

Here is the scoop. I run a dual Opteron machine with 3 gigs of ram, 4 raptors w/ raid, and a fat internet pipe. I help run a high traffic postnuke site and the server performance is horrible. I have long load times, and bad mysql connections. I figured that I would tune mysql and get better performance. When I start mysql I use this command…

$ (/usr/local/bin/safe_mysqld -O max_connections=2000 || /usr/local/bin/mysqld_safe -O max_connections=2000) &

I also have my-large.cnf in /etc. The only thing I changed in the file is thread_cache=40 instead of default 8 (I’m just playing around with numbers). Now that I change this variable it reports as 40 when I run…

$ mysqladmin variables | grep thread

thread_cache_size | 40

When I load my site, I still have the same problems as the server running w/ default settings. Now here is where I get confused. When I add –thread_cache_size 40 to my command line the load time speeds up to almost instant load, the CPU usage goes down, and I stop experiencing connection errors. The problem is that since I use postnuke I get errors on the page when the variable is in the command line.

My question is, does anyone know what I can do to speed up mysql w/ postnuke? Any help would be awesome.

Options: ReplyQuote

Written By
A configuration problem
October 25, 2004 03:14PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.