MySQL Forums
Forum List  »  Source, Builds, Binaries

MySQL Shell build on Arm (aarch64)
Posted by: Julio Suarez
Date: December 10, 2021 03:29PM

Hi,

It looks when you build mysql-server it doesn't also build mysql shell. I tried to clone mysql-shell and build it on Arm because prebuilt Arm binaries are not available.

I've run into an issue, and have a question.

First, I started with the following build command:

cmake .. -DMYSQL_SOURCE_DIR=../../mysql-server -DMYSQL_BUILD_DIR=../../mysql-server/bld -DHAVE_PYTHON=1

It complained about verifying the package year. To do this I added -DPACKAGE_YEAR=2021 as shown below:

cmake .. -DMYSQL_SOURCE_DIR=../../mysql-server -DMYSQL_BUILD_DIR=../../mysql-server/bld -DPACKAGE_YEAR=2021 -DHAVE_PYTHON=1

First question is, what is the purpose of this package year verification?

After this, I hit another issue related to python. I see the following error:

CMake Error at /usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS)
(Required is at least version "3.6")
Call Stack (most recent call first):
/usr/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.16/Modules/FindPythonLibs.cmake:310 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:661 (FIND_PACKAGE)


I tried adding the following:

-DPYTHON_INCLUDE_DIR=/usr/include -DPYTHON_LIBRARY=/usr/lib/aarch64-linux-gnu/libpython3.8.so

But see an error that say's "Couldn't detect Python's version.

Anyway, I'm looking for tips/help on how to get this built on Arm.

Thanks.

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL Shell build on Arm (aarch64)
1260
December 10, 2021 03:29PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.